Ce forum est maintenant fermé, seule cette archive statique reste consultable.
  FORUM Matbe.com
  OS, Software, Réseaux
  Autre

  WordPress sur Synology

Bas de page
Auteur Sujet :

WordPress sur Synology

n°73910
LostSoul
Belgian Beer Forever (en slip)
Posté le 03-11-2013 à 19:15:06  
 

Je viens de taper wordpress sur mon syno mais j'ai un petit souci
Mon provider (Telenet) ne permet pas d'ouvrir les ports < 4000, donc ...
- j'ai configuré mon webserver synology pour fonctionner sur le port 40080 (add port , et j'ai fait le routage via la config de mon modem ip externe:40080 -> ip interne du syno:40080; ça marche, je vois correctement la page par défaut du syno
- j'ai configuré un DDNS et ça marche aussi  
 
par contre, après l'install de wordpress, c'est nettement plus chelou :p
 
si j'accède à l'IP interne:40080/wordpress/ il me redirige sur le port 80 par défaut :o
du coup je subodore qu'il fait pareil de l'extérieur
 
Dans wordpress, quand je définis l'adresse du site, j'peux pas foutre de port dedans :o Si je fais ça, il plantouille en me disant qu'il peut pas créer le directory :o


---------------
Le cheval, c'est bon, mangez-en!  
[ www.in-wonderland.net | www.start64.com | www.majorgeeks.com | updt-bdnq ]
mood
Pub
Posté le 03-11-2013 à 19:15:06  
 

n°73911
charlydk
The power of Tiret...
Posté le 03-11-2013 à 20:12:16  
 

et si en externe tu mets le port 40080 mais que tu le redirige sur le 80 en interne ?


---------------
FERMETURE DU FORUM MATBE  => retrouvons-nous sur http://www.iwyt.net  :)
n°73912
LostSoul
Belgian Beer Forever (en slip)
Posté le 03-11-2013 à 20:22:55  
 

tu peux pas :p le truc de telenet ne permet pas de le faire :/


---------------
Le cheval, c'est bon, mangez-en!  
[ www.in-wonderland.net | www.start64.com | www.majorgeeks.com | updt-bdnq ]
n°73913
GregLu
ZzzzZZzZzZzzzZzZZz ...
Posté le 03-11-2013 à 21:49:56  
 

Change le port dans le fichier wp-config.php de Wordpress :p
 
Ou alors (Je sais plus si c'est via le wp-config ou le panel, ça fait longtemps que j'ai plus tatouillé WP), tu mets simplement le port à la fin dans les URL désignées dans le panel (Tu te logges en Admin, Paramètres » Général) : http://monwordpress.DDNS.ext:40080
 
Et depuis l'extérieur ça sera accessible :p


---------------
Survivants M@tbe : http://www.iwyt.net ;)
 
[:greglu] Aidez ღ Les Amis des Animaux Le Paradis sur terre ჴ Merci [:shumi4]
n°73914
LostSoul
Belgian Beer Forever (en slip)
Posté le 03-11-2013 à 22:26:51  
 

Je testerai ça
Sinon on peut le faire en ssh en modifiant les fichiers de config du web server aussi, un pote m'a posté l'astuce


---------------
Le cheval, c'est bon, mangez-en!  
[ www.in-wonderland.net | www.start64.com | www.majorgeeks.com | updt-bdnq ]
n°73915
charlydk
The power of Tiret...
Posté le 04-11-2013 à 09:29:58  
 

LostSoul a écrit :

tu peux pas :p le truc de telenet ne permet pas de le faire :/


Le routeur Telenet? :/
 
Chez moi j'ai mis un routeur derrière et je me sers du truc de BGC que pour le modem  :d


Message édité par charlydk le 04-11-2013 à 10:33:43

---------------
FERMETURE DU FORUM MATBE  => retrouvons-nous sur http://www.iwyt.net  :)
n°73916
charlydk
The power of Tiret...
Posté le 04-11-2013 à 09:31:04  
 

Tiens, dans ton synmic DNS, tu n'as pas l'option qui "intègre" le port dans l'url? Comme ça plus besoin du port dans l'URL

 

Genre http://my.ddns.org redirige vers chez toi mais sur le port 40080...

 

EDIT: mais si tu sais modifier le fichier de config comme Greg le dit c'est effectivement plus propre à priori :)


Message édité par charlydk le 04-11-2013 à 10:36:05

---------------
FERMETURE DU FORUM MATBE  => retrouvons-nous sur http://www.iwyt.net  :)
  FORUM Matbe.com
  OS, Software, Réseaux
  Autre

  WordPress sur Synology